summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2021-04-12 15:53:58 +0300
committerVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2021-04-12 15:53:58 +0300
commit06b43dad66ee0d55e5c53f7ed9f73e59e86dff4a (patch)
treea2546c99548c8c582358191a7190f876ce9aa550 /meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
parent06dc92d6f1c36c2f0c9b9ca31540c6cd17e515a7 (diff)
downloadopenbmc-06b43dad66ee0d55e5c53f7ed9f73e59e86dff4a.tar.xz
fru-fault-monitor: Enable OperationalStatus monitor feature
Currently, the phosphor-fru-fault-monitor updates the Asserted property of the Led Group D-Bus object by monitoring the `/xyz/openbmc_project/logging` object path. The intent behind this commit is to add another way to monitor the `xyz.openbmc_project.State.Decorator.OperationalStatus` interface of the Inventory D-Bus object, and check whether the Inventory D-Bus object is associated with the LED group D-Bus object, and then update the Asserted property of the LedManager. Since both these methods handle the faults differently, Only ONE of these 2 methods can be enabled and NOT both. The first way is supported by default. To turn OFF the default way AND turn ON this second way, Enable monitor-operational-status. Change-Id: I03701e599b6a120bc1f83da6f473b12f38660d64 Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
index 3f70891b4..b14f154ff 100644
--- a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
@@ -11,6 +11,8 @@ inherit obmc-phosphor-dbus-service obmc-phosphor-systemd
PACKAGECONFIG ??= ""
PACKAGECONFIG[use-json] = "--enable-use-json, --disable-use-json"
PACKAGECONFIG[use-lamp-test] = "--enable-use-lamp-test, --disable-use-lamp-test"
+PACKAGECONFIG[monitor-operational-status] = "--enable-monitor-operational-status, \
+ --disable-monitor-operational-status"
SYSTEMD_PACKAGES = "${PN} ${PN}-faultmonitor"
PACKAGE_BEFORE_PN += "${PN}-faultmonitor"