summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch176
1 files changed, 83 insertions, 93 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch b/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch
index f1505b8cd..373893a44 100644
--- a/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch
+++ b/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0001-Add-ast2600-intel-as-a-new-board.patch
@@ -1,4 +1,4 @@
-From efa949f82a1dd32b83eafe3fe58038abc04ecdbf Mon Sep 17 00:00:00 2001
+From 145ffdf95955562eddf96d0342bcdebd98f8dc95 Mon Sep 17 00:00:00 2001
From: Vernon Mauery <vernon.mauery@intel.com>
Date: Thu, 24 Oct 2019 14:06:33 -0700
Subject: [PATCH] Add ast2600-intel as a new board
@@ -7,23 +7,20 @@ Signed-off-by: Vernon Mauery <vernon.mauery@intel.com>
Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
Signed-off-by: Kuiying Wang <kuiying.wang@intel.com>
---
- arch/arm/dts/Makefile | 3 +
- arch/arm/dts/ast2600-intel.dts | 157 ++++++++++
- arch/arm/lib/interrupts.c | 5 +
- arch/arm/mach-aspeed/ast2600/Kconfig | 9 +
- arch/arm/mach-aspeed/ast2600/aspeed_scu_info.c | 1 +
- board/aspeed/ast2600_intel/Kconfig | 13 +
- board/aspeed/ast2600_intel/Makefile | 4 +
- board/aspeed/ast2600_intel/ast-espi.c | 298 ++++++++++++++++++
- board/aspeed/ast2600_intel/ast-irq.c | 399 +++++++++++++++++++++++++
- board/aspeed/ast2600_intel/ast-irq.h | 8 +
- board/aspeed/ast2600_intel/ast-timer.c | 59 ++++
- board/aspeed/ast2600_intel/intel.c | 176 +++++++++++
- cmd/Kconfig | 2 +-
- common/autoboot.c | 10 +
- common/board_r.c | 8 +-
- include/configs/evb_ast2600.h | 2 +-
- 16 files changed, 1148 insertions(+), 6 deletions(-)
+ arch/arm/dts/Makefile | 3 +-
+ arch/arm/dts/ast2600-intel.dts | 197 ++++++++++++++++
+ arch/arm/lib/interrupts.c | 5 +
+ arch/arm/mach-aspeed/ast2600/Kconfig | 8 +
+ board/aspeed/ast2600_intel/Kconfig | 13 ++
+ board/aspeed/ast2600_intel/Makefile | 4 +
+ board/aspeed/ast2600_intel/ast-espi.c | 298 ++++++++++++++++++++++++
+ board/aspeed/ast2600_intel/ast-irq.c | 399 +++++++++++++++++++++++++++++++++
+ board/aspeed/ast2600_intel/ast-irq.h | 8 +
+ board/aspeed/ast2600_intel/ast-timer.c | 59 +++++
+ board/aspeed/ast2600_intel/intel.c | 177 +++++++++++++++
+ cmd/Kconfig | 2 +-
+ common/autoboot.c | 10 +
+ 13 files changed, 1181 insertions(+), 2 deletions(-)
create mode 100644 arch/arm/dts/ast2600-intel.dts
create mode 100644 board/aspeed/ast2600_intel/Kconfig
create mode 100644 board/aspeed/ast2600_intel/Makefile
@@ -34,25 +31,27 @@ Signed-off-by: Kuiying Wang <kuiying.wang@intel.com>
create mode 100644 board/aspeed/ast2600_intel/intel.c
diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
-index d1d4dca340f8..38fe8113469e 100644
+index e4dae2937968..da8903123999 100644
--- a/arch/arm/dts/Makefile
+++ b/arch/arm/dts/Makefile
-@@ -680,6 +680,9 @@ dtb-$(CONFIG_TARGET_EVB_AST2500) += \
- dtb-$(CONFIG_TARGET_EVB_AST2600) += \
- ast2600-evb.dtb
-
-+dtb-$(CONFIG_TARGET_AST2600_INTEL) += \
+@@ -683,7 +683,8 @@ dtb-$(CONFIG_ARCH_ASPEED) += \
+ ast2600-fpga.dtb \
+ ast2600-rainier.dtb \
+ ast2600-slt.dtb \
+- ast2600-tacoma.dtb
++ ast2600-tacoma.dtb \
+ ast2600-intel.dtb
-+
- dtb-$(CONFIG_TARGET_FPGA_AST2600) += \
- ast2600-fpga.dtb
+
+ dtb-$(CONFIG_ARCH_STI) += stih410-b2260.dtb
diff --git a/arch/arm/dts/ast2600-intel.dts b/arch/arm/dts/ast2600-intel.dts
new file mode 100644
-index 000000000000..99788b21e444
+index 000000000000..9a15e204f83b
--- /dev/null
+++ b/arch/arm/dts/ast2600-intel.dts
-@@ -0,0 +1,157 @@
+@@ -0,0 +1,197 @@
++// SPDX-License-Identifier: GPL-2.0+
++// Copyright (c) 2019-2020 Intel Corporation
+/dts-v1/;
+
+#include "ast2600-u-boot.dtsi"
@@ -144,14 +143,31 @@ index 000000000000..99788b21e444
+
+&mdio {
+ status = "okay";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ ethphy1: ethernet-phy@1 {
++ reg = <0>;
++ };
++
++ ethphy2: ethernet-phy@2 {
++ reg = <0>;
++ };
++
++ ethphy3: ethernet-phy@3 {
++ reg = <0>;
++ };
++
++ ethphy4: ethernet-phy@4 {
++ reg = <0>;
++ };
+};
+
+&mac1 {
+ status = "okay";
-+
+ phy-mode = "rgmii";
++ phy-handle = <&ethphy2>;
+ pinctrl-names = "default";
-+ pinctrl-0 = <&pinctrl_mac2link_default &pinctrl_mdio2_default>;
++ pinctrl-0 = <&pinctrl_rgmii2_default &pinctrl_mac2link_default &pinctrl_mdio2_default>;
+};
+
+&fmc {
@@ -210,6 +226,28 @@ index 000000000000..99788b21e444
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_i2c9_default>;
+};
++
++&i2c9 {
++ status = "okay";
++
++ pinctrl-names = "default";
++ pinctrl-0 = <&pinctrl_i2c10_default>;
++};
++
++&i2c12 {
++ status = "okay";
++
++ pinctrl-names = "default";
++ pinctrl-0 = <&pinctrl_i2c13_default>;
++};
++
++&i2c13 {
++ status = "okay";
++
++ pinctrl-names = "default";
++ pinctrl-0 = <&pinctrl_i2c14_default>;
++};
+\ No newline at end of file
diff --git a/arch/arm/lib/interrupts.c b/arch/arm/lib/interrupts.c
index ee775ce5d264..8c985532afb4 100644
--- a/arch/arm/lib/interrupts.c
@@ -245,14 +283,13 @@ index ee775ce5d264..8c985532afb4 100644
{
efi_restore_gd();
diff --git a/arch/arm/mach-aspeed/ast2600/Kconfig b/arch/arm/mach-aspeed/ast2600/Kconfig
-index 3c208ff3da67..a2a2fe0e24a8 100644
+index dd991e87c795..7ccbb0b5e0ea 100644
--- a/arch/arm/mach-aspeed/ast2600/Kconfig
+++ b/arch/arm/mach-aspeed/ast2600/Kconfig
-@@ -24,9 +24,18 @@ config TARGET_FPGA_AST2600
- FPGA-AST2600 is Aspeed FPGA board for AST2600 chip.
- This is mainly for internal development. Note that
- most implementation is co-code with EVB-AST2600.
-+
+@@ -51,6 +51,13 @@ config TARGET_SLT_AST2600
+ help
+ SLT-AST2600 is Aspeed SLT board for AST2600 chip.
+
+config TARGET_AST2600_INTEL
+ bool "AST2600-INTEL"
+ depends on ASPEED_AST2600
@@ -262,23 +299,14 @@ index 3c208ff3da67..a2a2fe0e24a8 100644
+
endchoice
- source "board/aspeed/evb_ast2600/Kconfig"
+ source "board/aspeed/evb_ast2600a0/Kconfig"
+@@ -59,5 +66,6 @@ source "board/aspeed/ncsi_ast2600a0/Kconfig"
+ source "board/aspeed/ncsi_ast2600a1/Kconfig"
source "board/aspeed/fpga_ast2600/Kconfig"
+ source "board/aspeed/slt_ast2600/Kconfig"
+source "board/aspeed/ast2600_intel/Kconfig"
endif
-diff --git a/arch/arm/mach-aspeed/ast2600/aspeed_scu_info.c b/arch/arm/mach-aspeed/ast2600/aspeed_scu_info.c
-index c31e8a3614b0..84ca9f68aee7 100644
---- a/arch/arm/mach-aspeed/ast2600/aspeed_scu_info.c
-+++ b/arch/arm/mach-aspeed/ast2600/aspeed_scu_info.c
-@@ -88,6 +88,7 @@ extern void
- aspeed_sys_reset_info(void)
- {
- u32 rest = readl(ASPEED_SYS_RESET_CTRL);
-+ printf("RST: %08x\n", rest);
-
- if (rest & SYS_PWR_RESET_FLAG) {
- printf("RST : Power On \n");
diff --git a/board/aspeed/ast2600_intel/Kconfig b/board/aspeed/ast2600_intel/Kconfig
new file mode 100644
index 000000000000..b841dab60c76
@@ -1098,10 +1126,10 @@ index 000000000000..cf8c69aba5d3
+}
diff --git a/board/aspeed/ast2600_intel/intel.c b/board/aspeed/ast2600_intel/intel.c
new file mode 100644
-index 000000000000..b5d8dd36d20b
+index 000000000000..a02e246d0d81
--- /dev/null
+++ b/board/aspeed/ast2600_intel/intel.c
-@@ -0,0 +1,176 @@
+@@ -0,0 +1,177 @@
+/* Intel customizations of Das U-Boot */
+#include <common.h>
+#include <asm/gpio.h>
@@ -1139,6 +1167,7 @@ index 000000000000..b5d8dd36d20b
+ return value <= 0 ? 0 : 1;
+}
+
++#define SCU_BASE 0x1E6E2000
+int misc_init_r(void)
+{
+ /* This is called near the end of the _r init sequence */
@@ -1279,10 +1308,10 @@ index 000000000000..b5d8dd36d20b
+}
+#endif
diff --git a/cmd/Kconfig b/cmd/Kconfig
-index 92736f2d6612..f64a2595da65 100644
+index d5aa204290bd..89f6668b788e 100644
--- a/cmd/Kconfig
+++ b/cmd/Kconfig
-@@ -1862,7 +1862,7 @@ config CMD_DIAG
+@@ -1876,7 +1876,7 @@ config CMD_DIAG
config CMD_IRQ
bool "irq - Show information about interrupts"
@@ -1316,45 +1345,6 @@ index 94133eaeda78..5e69000b848b 100644
if (bootdelay >= 0)
abort = __abortboot(bootdelay);
-diff --git a/common/board_r.c b/common/board_r.c
-index 472987d5d52f..a7f5371bac71 100644
---- a/common/board_r.c
-+++ b/common/board_r.c
-@@ -673,6 +673,10 @@ static init_fnc_t init_sequence_r[] = {
- #if defined(CONFIG_ARM) || defined(CONFIG_NDS32) || defined(CONFIG_RISCV) || \
- defined(CONFIG_SANDBOX)
- board_init, /* Setup chipselects */
-+ interrupt_init,
-+#ifdef CONFIG_ARM
-+ initr_enable_interrupts,
-+#endif
- #endif
- /*
- * TODO: printing of the clock inforamtion of the board is now
-@@ -771,10 +775,6 @@ static init_fnc_t init_sequence_r[] = {
- #ifdef CONFIG_CMD_KGDB
- initr_kgdb,
- #endif
-- interrupt_init,
--#ifdef CONFIG_ARM
-- initr_enable_interrupts,
--#endif
- #if defined(CONFIG_MICROBLAZE) || defined(CONFIG_M68K)
- timer_init, /* initialize timer */
- #endif
-diff --git a/include/configs/evb_ast2600.h b/include/configs/evb_ast2600.h
-index 3a12f2f0d43c..91a42f2522e2 100644
---- a/include/configs/evb_ast2600.h
-+++ b/include/configs/evb_ast2600.h
-@@ -18,7 +18,7 @@
-
- /* Environment */
- #define CONFIG_ENV_SIZE 0x10000
--#define CONFIG_ENV_OFFSET 0x60000
-+#define CONFIG_ENV_OFFSET 0x2400000
- #define CONFIG_ENV_SECT_SIZE (4 << 10)
-
- #endif /* __CONFIG_H */
--
2.7.4