summaryrefslogtreecommitdiff
path: root/special-mode-mgr/CMakeLists.txt
diff options
context:
space:
mode:
authorRichard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>2019-11-04 12:49:35 +0300
committerThomaiyar, Richard Marian <richard.marian.thomaiyar@intel.com>2019-11-07 21:12:59 +0300
commitb21586a85b6b434dc90b35285f363f97384fcdd4 (patch)
tree22b5967baf14acdd3dce995b5f79a6e0619bd097 /special-mode-mgr/CMakeLists.txt
parent27889afa22c5f2b933b7d25cc0cde1db0281e60f (diff)
downloadprovingground-b21586a85b6b434dc90b35285f363f97384fcdd4.tar.xz
Added support for validation unsecure mode
Support added for validation unsecure mode under compile flag which will be enabled only with debug-tweaks. Default is disabled. Tested: Along with intel-ipmi-oem changes for set security mode command 1. Verified that system goes to validation unsecure mode as per the Set Security Mode command. 2. Able to execute all the manufacturing mode command in this state 3. Mode preserved during reboot and not in reset to defaults Change-Id: Ice33d2c02ac8c0c0276ba16651f8acbd3d5b8cd4 Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
Diffstat (limited to 'special-mode-mgr/CMakeLists.txt')
-rw-r--r--special-mode-mgr/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/special-mode-mgr/CMakeLists.txt b/special-mode-mgr/CMakeLists.txt
index cefe6ff..ea54904 100644
--- a/special-mode-mgr/CMakeLists.txt
+++ b/special-mode-mgr/CMakeLists.txt
@@ -37,6 +37,16 @@ target_link_libraries(${PROJECT_NAME} phosphor_logging)
link_directories(${EXTERNAL_INSTALL_LOCATION}/lib)
+option(
+ BMC_VALIDATION_UNSECURE_FEATURE
+ "Enables unsecure features required by validation. Note: must
+ be turned off for production images."
+ OFF)
+target_compile_definitions(${PROJECT_NAME}
+ PRIVATE
+ $<$<BOOL:${BMC_VALIDATION_UNSECURE_FEATURE}>:
+ -DBMC_VALIDATION_UNSECURE_FEATURE>)
+
set(SERVICE_FILES ${PROJECT_SOURCE_DIR}/specialmodemgr.service)
install(TARGETS ${PROJECT_NAME} DESTINATION bin)