summaryrefslogtreecommitdiff
path: root/special-mode-mgr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'special-mode-mgr/CMakeLists.txt')
-rw-r--r--special-mode-mgr/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/special-mode-mgr/CMakeLists.txt b/special-mode-mgr/CMakeLists.txt
index cefe6ff..ea54904 100644
--- a/special-mode-mgr/CMakeLists.txt
+++ b/special-mode-mgr/CMakeLists.txt
@@ -37,6 +37,16 @@ target_link_libraries(${PROJECT_NAME} phosphor_logging)
link_directories(${EXTERNAL_INSTALL_LOCATION}/lib)
+option(
+ BMC_VALIDATION_UNSECURE_FEATURE
+ "Enables unsecure features required by validation. Note: must
+ be turned off for production images."
+ OFF)
+target_compile_definitions(${PROJECT_NAME}
+ PRIVATE
+ $<$<BOOL:${BMC_VALIDATION_UNSECURE_FEATURE}>:
+ -DBMC_VALIDATION_UNSECURE_FEATURE>)
+
set(SERVICE_FILES ${PROJECT_SOURCE_DIR}/specialmodemgr.service)
install(TARGETS ${PROJECT_NAME} DESTINATION bin)