summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAppaRao Puli <apparao.puli@linux.intel.com>2019-10-18 14:46:08 +0300
committerAppaRao Puli <apparao.puli@linux.intel.com>2019-10-30 21:23:12 +0300
commita6349918ad2c88533c6d09bb876812375a19f2c4 (patch)
tree3d77485f6d35b097cbf656ddd3c49bbe2884c660 /CMakeLists.txt
parent52efa5d69092219f41e1634163a3e4fa598c596c (diff)
downloadbmcweb-a6349918ad2c88533c6d09bb876812375a19f2c4.tar.xz
Added OemComputerSystems and properties for provisioning
- Added OemComputerSystems Schema for provisioning properties - Added "ProvisioningStatus" Oem property with EnumType 1) NotProvisioned 2) ProvisionedButNotLocked 3) ProvisionedAndLocked Intel secures platform firmware components using Intel PFR mechanism. This may differ for other Oem's(non-intel platforms) but the properties like Provisioned, Locked states should be of generic as per NIST SP 800-193. Added build time flag to enable/disable PFR supported platforms. Tested: - By default provisioning feature is OFF, using GET method on below URI verified Oem Property and observed no such property. This is default behaviour on upstream. URI: /redfish/v1/Systems/system Response: No "Oem" property. - Enabled provisioning feature in Intel platforms and Verified using Systems URI. Ran the redfish validator tool and no new issues found due to this change. URI: /redfish/v1/Systems/system RESPONSE: ..... "Oem": { "OpenBmc": { "FirmwareProvisioning": { "ProvisioningStatus": "NotProvisioned" } } } ..... Signed-off-by: AppaRao Puli <apparao.puli@linux.intel.com> Change-Id: I674e6075263f4fa2962637d3add47393a1ff0c0b
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40b570633c..956e173396 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,12 @@ option (
'/redfish/v1/Systems/system/LogServices/EventLog/Entries'."
OFF
)
+option (
+ BMCWEB_ENABLE_REDFISH_PROVISIONING_FEATURE
+ "Enable provisioning feature support in redfish. Paths are under
+ '/redfish/v1/Systems/system/'."
+ OFF
+)
# Insecure options. Every option that starts with a BMCWEB_INSECURE flag should
# not be enabled by default for any platform, unless the author fully
@@ -359,6 +365,8 @@ target_compile_definitions (
-DBMCWEB_ENABLE_REDFISH_DBUS_LOG_ENTRIES>
$<$<BOOL:${BMCWEB_INSECURE_ENABLE_REDFISH_FW_TFTP_UPDATE}>:
-DBMCWEB_INSECURE_ENABLE_REDFISH_FW_TFTP_UPDATE>
+ $<$<BOOL:${BMCWEB_ENABLE_REDFISH_PROVISIONING_FEATURE}>:
+ -DBMCWEB_ENABLE_REDFISH_PROVISIONING_FEATURE>
)
# configure and install systemd unit files