summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40b570633c..956e173396 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,12 @@ option (
'/redfish/v1/Systems/system/LogServices/EventLog/Entries'."
OFF
)
+option (
+ BMCWEB_ENABLE_REDFISH_PROVISIONING_FEATURE
+ "Enable provisioning feature support in redfish. Paths are under
+ '/redfish/v1/Systems/system/'."
+ OFF
+)
# Insecure options. Every option that starts with a BMCWEB_INSECURE flag should
# not be enabled by default for any platform, unless the author fully
@@ -359,6 +365,8 @@ target_compile_definitions (
-DBMCWEB_ENABLE_REDFISH_DBUS_LOG_ENTRIES>
$<$<BOOL:${BMCWEB_INSECURE_ENABLE_REDFISH_FW_TFTP_UPDATE}>:
-DBMCWEB_INSECURE_ENABLE_REDFISH_FW_TFTP_UPDATE>
+ $<$<BOOL:${BMCWEB_ENABLE_REDFISH_PROVISIONING_FEATURE}>:
+ -DBMCWEB_ENABLE_REDFISH_PROVISIONING_FEATURE>
)
# configure and install systemd unit files