summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNan Zhou <nanzhoumails@gmail.com>2022-09-10 21:11:41 +0300
committerNan Zhou <nanzhoumails@gmail.com>2022-09-22 02:44:37 +0300
commitc33a039b56fc5789ae71289adaca1e572a48d318 (patch)
tree8b936ca291537cebebf6bf505e565bff9635f511 /meson.build
parent6ab9ad5492b9203c7dd8fb3e8c59d37bbc455cde (diff)
downloadbmcweb-c33a039b56fc5789ae71289adaca1e572a48d318.tar.xz
treewide: reorganize unit tests
Like other C++ projects, unit tests normally are in a separate repo and respect the folder structure of the file under test. This commit deleted all "ut" folder and move tests to a "test" folder. The test folder also has similar structure as the main folder. This commit also made neccessary include changes to make codes compile. Unused tests are untouched. Tested: unit test passed. Reference: [1] https://github.com/grpc/grpc/tree/master/test [2] https://github.com/boostorg/core/tree/414dfb466878af427d33b36e6ccf84d21c0e081b/test [3] Many other OpenBMC repos: https://github.com/openbmc/entity-manager/tree/master/test [4] https://stackoverflow.com/questions/2360734/whats-a-good-directory-structure-for-larger-c-projects-using-makefile Signed-off-by: Nan Zhou <nanzhoumails@gmail.com> Change-Id: I4521c7ef5fa03c47cca5c146d322bbb51365ee96
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build46
1 files changed, 23 insertions, 23 deletions
diff --git a/meson.build b/meson.build
index b3425beb85..7e58791aa2 100644
--- a/meson.build
+++ b/meson.build
@@ -391,29 +391,29 @@ executable(
)
srcfiles_unittest = [
- 'http/ut/utility_test.cpp',
- 'http/ut/router_test.cpp',
- 'include/google/google_service_root_test.cpp',
- 'include/ut/dbus_utility_test.cpp',
- 'include/ut/http_utility_test.cpp',
- 'include/ut/human_sort_test.cpp',
- 'include/ut/multipart_test.cpp',
- 'include/ut/openbmc_dbus_rest_test.cpp',
- 'redfish-core/include/utils/query_param_test.cpp',
- 'redfish-core/lib/ut/log_services_dump_test.cpp',
- 'redfish-core/lib/ut/service_root_test.cpp',
- 'redfish-core/lib/ut/thermal_subsystem_test.cpp',
- 'redfish-core/lib/chassis_test.cpp',
- 'redfish-core/ut/configfile_test.cpp',
- 'redfish-core/ut/hex_utils_test.cpp',
- 'redfish-core/ut/ip_utils_test.cpp',
- 'redfish-core/ut/json_utils_test.cpp',
- 'redfish-core/ut/lock_test.cpp',
- 'redfish-core/ut/privileges_test.cpp',
- 'redfish-core/ut/registries_test.cpp',
- 'redfish-core/ut/stl_utils_test.cpp',
- 'redfish-core/ut/time_utils_test.cpp',
- 'src/crow_getroutes_test.cpp',
+ 'test/http/crow_getroutes_test.cpp',
+ 'test/http/router_test.cpp',
+ 'test/http/utility_test.cpp',
+ 'test/include/dbus_utility_test.cpp',
+ 'test/include/google/google_service_root_test.cpp',
+ 'test/include/http_utility_test.cpp',
+ 'test/include/human_sort_test.cpp',
+ 'test/include/ibm/configfile_test.cpp',
+ 'test/include/ibm/lock_test.cpp',
+ 'test/include/multipart_test.cpp',
+ 'test/include/openbmc_dbus_rest_test.cpp',
+ 'test/redfish-core/include/privileges_test.cpp',
+ 'test/redfish-core/include/registries_test.cpp',
+ 'test/redfish-core/include/utils/hex_utils_test.cpp',
+ 'test/redfish-core/include/utils/ip_utils_test.cpp',
+ 'test/redfish-core/include/utils/json_utils_test.cpp',
+ 'test/redfish-core/include/utils/query_param_test.cpp',
+ 'test/redfish-core/include/utils/stl_utils_test.cpp',
+ 'test/redfish-core/include/utils/time_utils_test.cpp',
+ 'test/redfish-core/lib/chassis_test.cpp',
+ 'test/redfish-core/lib/log_services_dump_test.cpp',
+ 'test/redfish-core/lib/service_root_test.cpp',
+ 'test/redfish-core/lib/thermal_subsystem_test.cpp',
]
if(get_option('tests').enabled())