summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build46
1 files changed, 23 insertions, 23 deletions
diff --git a/meson.build b/meson.build
index b3425beb85..7e58791aa2 100644
--- a/meson.build
+++ b/meson.build
@@ -391,29 +391,29 @@ executable(
)
srcfiles_unittest = [
- 'http/ut/utility_test.cpp',
- 'http/ut/router_test.cpp',
- 'include/google/google_service_root_test.cpp',
- 'include/ut/dbus_utility_test.cpp',
- 'include/ut/http_utility_test.cpp',
- 'include/ut/human_sort_test.cpp',
- 'include/ut/multipart_test.cpp',
- 'include/ut/openbmc_dbus_rest_test.cpp',
- 'redfish-core/include/utils/query_param_test.cpp',
- 'redfish-core/lib/ut/log_services_dump_test.cpp',
- 'redfish-core/lib/ut/service_root_test.cpp',
- 'redfish-core/lib/ut/thermal_subsystem_test.cpp',
- 'redfish-core/lib/chassis_test.cpp',
- 'redfish-core/ut/configfile_test.cpp',
- 'redfish-core/ut/hex_utils_test.cpp',
- 'redfish-core/ut/ip_utils_test.cpp',
- 'redfish-core/ut/json_utils_test.cpp',
- 'redfish-core/ut/lock_test.cpp',
- 'redfish-core/ut/privileges_test.cpp',
- 'redfish-core/ut/registries_test.cpp',
- 'redfish-core/ut/stl_utils_test.cpp',
- 'redfish-core/ut/time_utils_test.cpp',
- 'src/crow_getroutes_test.cpp',
+ 'test/http/crow_getroutes_test.cpp',
+ 'test/http/router_test.cpp',
+ 'test/http/utility_test.cpp',
+ 'test/include/dbus_utility_test.cpp',
+ 'test/include/google/google_service_root_test.cpp',
+ 'test/include/http_utility_test.cpp',
+ 'test/include/human_sort_test.cpp',
+ 'test/include/ibm/configfile_test.cpp',
+ 'test/include/ibm/lock_test.cpp',
+ 'test/include/multipart_test.cpp',
+ 'test/include/openbmc_dbus_rest_test.cpp',
+ 'test/redfish-core/include/privileges_test.cpp',
+ 'test/redfish-core/include/registries_test.cpp',
+ 'test/redfish-core/include/utils/hex_utils_test.cpp',
+ 'test/redfish-core/include/utils/ip_utils_test.cpp',
+ 'test/redfish-core/include/utils/json_utils_test.cpp',
+ 'test/redfish-core/include/utils/query_param_test.cpp',
+ 'test/redfish-core/include/utils/stl_utils_test.cpp',
+ 'test/redfish-core/include/utils/time_utils_test.cpp',
+ 'test/redfish-core/lib/chassis_test.cpp',
+ 'test/redfish-core/lib/log_services_dump_test.cpp',
+ 'test/redfish-core/lib/service_root_test.cpp',
+ 'test/redfish-core/lib/thermal_subsystem_test.cpp',
]
if(get_option('tests').enabled())