summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor/flash
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2022-06-10 21:54:36 +0300
committerWilliam A. Kennington III <wak@google.com>2022-06-11 21:52:17 +0300
commitc562347d8710ef5fa437ca6a0153e0219575231d (patch)
tree340f85ced0d963b046fe2d1129f198931db90e2e /meta-google/recipes-phosphor/flash
parentd99d91e7df77882a27ae89f4745fc63580a00662 (diff)
downloadopenbmc-c562347d8710ef5fa437ca6a0153e0219575231d.tar.xz
meta-google: gbmc-update: Fix unpacking nested directories
We don't actually store the firmware at a top-level directory, we expect it to be stored in a hierarchy of directories. Change-Id: I04eebb166d34616b346b401d1201574939cab60c Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-phosphor/flash')
-rw-r--r--meta-google/recipes-phosphor/flash/gbmc-update.bb1
-rw-r--r--meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh2
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-google/recipes-phosphor/flash/gbmc-update.bb b/meta-google/recipes-phosphor/flash/gbmc-update.bb
index c0a3f7a9e8..48f645e20d 100644
--- a/meta-google/recipes-phosphor/flash/gbmc-update.bb
+++ b/meta-google/recipes-phosphor/flash/gbmc-update.bb
@@ -12,6 +12,7 @@ SRC_URI += " \
FILES:${PN} += "${datadir}/gbmc-br-dhcp"
RDEPENDS:${PN} += "curl"
+RDEPENDS:${PN} += "tar"
do_install() {
install -d ${D}${datadir}/gbmc-br-dhcp
diff --git a/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh b/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh
index 34beed335e..0124e38aee 100644
--- a/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh
+++ b/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh
@@ -57,7 +57,7 @@ gbmc_upgrade_fetch() (
while true; do
local st=()
curl -LSsk --max-time $((timeout - SECONDS)) "$bootfile_url" |
- tar "${tflags[@]}" -xC "$tmpdir" "firmware-gbmc/$machine" \
+ tar "${tflags[@]}" --wildcards -xC "$tmpdir" "*/firmware-gbmc/$machine" \
&& st=("${PIPESTATUS[@]}") || st=("${PIPESTATUS[@]}")
# Curl failures should continue
if (( st[0] == 0 )); then