summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor/flash
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-phosphor/flash')
-rw-r--r--meta-google/recipes-phosphor/flash/gbmc-update.bb1
-rw-r--r--meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh2
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-google/recipes-phosphor/flash/gbmc-update.bb b/meta-google/recipes-phosphor/flash/gbmc-update.bb
index c0a3f7a9e8..48f645e20d 100644
--- a/meta-google/recipes-phosphor/flash/gbmc-update.bb
+++ b/meta-google/recipes-phosphor/flash/gbmc-update.bb
@@ -12,6 +12,7 @@ SRC_URI += " \
FILES:${PN} += "${datadir}/gbmc-br-dhcp"
RDEPENDS:${PN} += "curl"
+RDEPENDS:${PN} += "tar"
do_install() {
install -d ${D}${datadir}/gbmc-br-dhcp
diff --git a/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh b/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh
index 34beed335e..0124e38aee 100644
--- a/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh
+++ b/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh
@@ -57,7 +57,7 @@ gbmc_upgrade_fetch() (
while true; do
local st=()
curl -LSsk --max-time $((timeout - SECONDS)) "$bootfile_url" |
- tar "${tflags[@]}" -xC "$tmpdir" "firmware-gbmc/$machine" \
+ tar "${tflags[@]}" --wildcards -xC "$tmpdir" "*/firmware-gbmc/$machine" \
&& st=("${PIPESTATUS[@]}") || st=("${PIPESTATUS[@]}")
# Curl failures should continue
if (( st[0] == 0 )); then