summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-04-14 19:24:47 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-04-17 17:51:12 +0300
commitbccaff3439442ca820760c90da4a2308d3d61b0e (patch)
tree8c190c31e50a28f79d588cc49e101ddafb7b4a28 /meta-openpower/recipes-phosphor
parent65682ac6176742b7d81b64c71d7a37913a39470b (diff)
downloadopenbmc-bccaff3439442ca820760c90da4a2308d3d61b0e.tar.xz
treewide: reduce append operators on SRC_URI
In a base bb file where we are setting the primary git repository, it is rare that we need to `SRC_URI +=`. This is an unnecessary pattern that seems to have been copied throughout the repository. Remove the pattern where appropriate and simply set SRC_URI directly. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I430186a82f9582ba6196f5bf66b659af4092b48d
Diffstat (limited to 'meta-openpower/recipes-phosphor')
-rw-r--r--meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/logging/python3-sbe-log-parsers_git.bb2
5 files changed, 5 insertions, 5 deletions
diff --git a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
index 8f781f6354..d9cf89d4e9 100644
--- a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
+++ b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
@@ -65,7 +65,7 @@ FILES:${PN} += "${datadir}/dbus-1/system.d/org.open_power.Software.Host.Updater.
S = "${WORKDIR}/git"
-SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/openpower-pnor-code-mgmt;branch=master;protocol=https"
SRCREV = "9b837f61632ebb522a4f5cd297cbe1c477c59753"
diff --git a/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb b/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
index 57256d8af1..c9443efeba 100644
--- a/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
+++ b/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
@@ -13,5 +13,5 @@ S = "${WORKDIR}/git"
SYSTEMD_SERVICE:${PN} += "pnorboot.service"
-SRC_URI += "git://github.com/shenki/aspeed-lpc-control;branch=master;protocol=https"
+SRC_URI = "git://github.com/shenki/aspeed-lpc-control;branch=master;protocol=https"
SRCREV = "af42b7ff01e71c0dd4c60214dd46ed487611f36d"
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 59ed688679..43695548de 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -10,7 +10,7 @@ S = "${WORKDIR}/git"
inherit meson obmc-phosphor-utils pkgconfig
inherit systemd
-SRC_URI += "git://github.com/openbmc/openpower-proc-control;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/openpower-proc-control;branch=master;protocol=https"
SRCREV = "be14ec2d4350ba245538ad0330587af809fa31c2"
DEPENDS += " \
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
index 8510cee01a..51bb30da5a 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
@@ -19,7 +19,7 @@ HOSTIPMI_PROVIDER_LIBRARY += "libhiomap.so"
S = "${WORKDIR}/git"
-SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-flash;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/openpower-host-ipmi-flash;branch=master;protocol=https"
SRCREV = "7a50cbe5a45002886e9eceb127ca5ca6f70c7efc"
EXTRA_OEMESON:append = " -Dtests=disabled"
diff --git a/meta-openpower/recipes-phosphor/logging/python3-sbe-log-parsers_git.bb b/meta-openpower/recipes-phosphor/logging/python3-sbe-log-parsers_git.bb
index 986f588c58..35d7030d3a 100644
--- a/meta-openpower/recipes-phosphor/logging/python3-sbe-log-parsers_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/python3-sbe-log-parsers_git.bb
@@ -9,7 +9,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE_PROLOG;md5=d8e5f403c98fd80dcea90b9cc8cd083c"
S = "${WORKDIR}/git"
-SRC_URI += "git://git@github.com/open-power/sbe;branch="master-p10";protocol=ssh;protocol=https"
+SRC_URI = "git://git@github.com/open-power/sbe;branch="master-p10";protocol=ssh;protocol=https"
SRCREV = "f8ee8cfad2cf2a53e78789633ddffc192f5a197e"
inherit setuptools3