summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/host
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-phosphor/host
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-phosphor/host')
-rw-r--r--meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb24
-rw-r--r--meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb37
2 files changed, 28 insertions, 33 deletions
diff --git a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
index ffe2f366ea..6cc31b4641 100644
--- a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
@@ -1,26 +1,24 @@
SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER"
DESCRIPTION = "A host control implementation suitable for OpenPOWER systems."
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
-inherit skeleton-gdbus
-inherit obmc-phosphor-dbus-service
-inherit pkgconfig
-
PROVIDES += "virtual/obmc-host-ctl"
-RPROVIDES:${PN} += "virtual-obmc-host-ctl"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
SKELETON_DIR = "op-hostctl"
-
-FMT = "org.openbmc.control.Host@{0}.service"
-DBUS_SERVICE:${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
SYSTEMD_SERVICE:${PN} = " \
op-start-host@.service \
"
-
START_TMPL = "op-start-host@.service"
START_TGTFMT = "obmc-host-startmin@{1}.target"
START_INSTFMT = "op-start-host@{0}.service"
START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
-
SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
+
+inherit skeleton-gdbus
+inherit obmc-phosphor-dbus-service
+inherit pkgconfig
+
+RPROVIDES:${PN} += "virtual-obmc-host-ctl"
+
+FMT = "org.openbmc.control.Host@{0}.service"
+DBUS_SERVICE:${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
diff --git a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
index 4afbc14a4f..05ded76597 100644
--- a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
+++ b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
@@ -1,35 +1,35 @@
SUMMARY = "Phosphor OpenBMC Post Code Daemon"
DESCRIPTION = "Phosphor OpenBMC Post Code Daemon"
HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd"
-PR = "r1"
-PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-inherit meson
-inherit pkgconfig
-inherit systemd
-
-PACKAGECONFIG ?= ""
-PACKAGECONFIG[7seg] = "-D7seg=enabled,-D7seg=disabled,,udev"
-
DEPENDS += "sdbusplus"
DEPENDS += "sdeventplus"
DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "systemd"
DEPENDS += "libgpiod"
+SRCREV = "aee6540154f2ac8ea510efacd2785868c1898a7d"
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[7seg] = "-D7seg=enabled,-D7seg=disabled,,udev"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
-S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-host-postd;branch=master;protocol=https"
-SRCREV = "aee6540154f2ac8ea510efacd2785868c1898a7d"
+S = "${WORKDIR}/git"
SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
-POST_CODE_BYTES ?= "1"
-7SEG_GPIO ?= "0"
-
SERVICE_FILE = "lpcsnoop.service"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE:${PN} += "${SERVICE_FILE}"
+SERVICE_FILE_7SEG = " \
+ postcode-7seg@.service \
+ postcode-7seg@${POSTCODE_SEVENSEG_DEVICE}.service \
+"
+SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', '7seg', '${SERVICE_FILE_7SEG}', '', d)}"
+
+inherit meson
+inherit pkgconfig
+inherit systemd
EXTRA_OEMESON:append = " \
-Dsnoop-device=${SNOOP_DEVICE} \
@@ -37,9 +37,6 @@ EXTRA_OEMESON:append = " \
-Dtests=disabled \
"
+POST_CODE_BYTES ?= "1"
+7SEG_GPIO ?= "0"
POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
-SERVICE_FILE_7SEG = " \
- postcode-7seg@.service \
- postcode-7seg@${POSTCODE_SEVENSEG_DEVICE}.service \
-"
-SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', '7seg', '${SERVICE_FILE_7SEG}', '', d)}"