summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/sel-logger
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-phosphor/sel-logger
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-phosphor/sel-logger')
-rw-r--r--meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb25
1 files changed, 10 insertions, 15 deletions
diff --git a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
index 6b773dff12..d9da9779b7 100644
--- a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
+++ b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
@@ -1,6 +1,3 @@
-SUMMARY = "Journal IPMI SEL Logger"
-DESCRIPTION = "Utility to write IPMI SEL records to the journal"
-
# SEL Logger has the ability to monitor and automatically log SEL records for
# various types of events, but this is disabled by default. The following
# flags can be set in a .bbappend to enable specific types of event
@@ -8,26 +5,16 @@ DESCRIPTION = "Utility to write IPMI SEL records to the journal"
#
# SEL_LOGGER_MONITOR_THRESHOLD_EVENTS:
# Monitors and logs SEL records for threshold sensor events
-
-inherit pkgconfig meson systemd
-S = "${WORKDIR}/git"
-
+SUMMARY = "Journal IPMI SEL Logger"
+DESCRIPTION = "Utility to write IPMI SEL records to the journal"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
DEPENDS += " \
boost \
sdbusplus \
systemd \
"
-
-SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=https;branch=master"
SRCREV = "628058fadb9d4c35dbe2c9636f3e6e93767e9526"
-
-PV = "0.1+git${SRCPV}"
-
-SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.Logging.IPMI.service"
-
PACKAGECONFIG ??= ""
PACKAGECONFIG[log-threshold] = "-Dlog-threshold=true,-Dlog-threshold=false,"
PACKAGECONFIG[log-pulse] = "-Dlog-pulse=true,-Dlog-pulse=false,"
@@ -35,3 +22,11 @@ PACKAGECONFIG[log-watchdog] = "-Dlog-watchdog=true,-Dlog-watchdog=false,"
PACKAGECONFIG[log-alarm] = "-Dlog-alarm=true,-Dlog-alarm=false,"
PACKAGECONFIG[send-to-logger] = "-Dsend-to-logger=true,-Dsend-to-logger=false,phosphor-logging"
PACKAGECONFIG[clears-sel] = "-Dclears-sel=true,-Dclears-sel=false"
+PV = "0.1+git${SRCPV}"
+
+SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.Logging.IPMI.service"
+
+inherit pkgconfig meson systemd