summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/settings
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-phosphor/settings
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-phosphor/settings')
-rw-r--r--meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb13
-rw-r--r--meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb16
2 files changed, 11 insertions, 18 deletions
diff --git a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb
index 4aac9bf60f..11271a47fe 100644
--- a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb
+++ b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb
@@ -1,25 +1,22 @@
SUMMARY = "Default settings"
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit phosphor-settings-manager
-inherit native
+PROVIDES += "virtual/phosphor-settings-defaults"
+PR = "r1"
SRC_URI += "file://defaults.yaml"
SRC_URI += "file://host-template.yaml"
-PROVIDES += "virtual/phosphor-settings-defaults"
-
SETTINGS_HOST_TEMPLATES:append = " host-template.yaml"
-
S = "${WORKDIR}"
+inherit phosphor-settings-manager
+inherit native
+
do_install() {
DEST=${D}${settings_datadir}
install -d ${DEST}
install defaults.yaml ${DEST}
-
for i in ${OBMC_HOST_INSTANCES};
do
for f in ${SETTINGS_HOST_TEMPLATES};
diff --git a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb
index a67d6819dc..9122522ba5 100644
--- a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb
+++ b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-read-settings-mrw-native.bb
@@ -1,31 +1,25 @@
# Generates MRW settings override yaml for phosphor-settings-manager
# The default YAML file, mrw-override-settings.yaml, is empty, therefore no
# settings will be overwritten. To override, modify mrw-override-settings.yaml.
-
SUMMARY = "Generates MRW settings override YAML for phosphor-settings-manager."
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit phosphor-settings-manager
-inherit mrw-xml
-inherit native
-
DEPENDS += "mrw-native mrw-perl-tools-native"
+PR = "r1"
SRC_URI += "file://mrw-override-settings.yaml"
S = "${WORKDIR}"
-MRW_EXPRESSION_VARS ?= ""
+inherit phosphor-settings-manager
+inherit mrw-xml
+inherit native
do_install() {
DEST=${D}${config_datadir}
install -D mrw-override-settings.yaml ${DEST}/mrw-override-settings.yaml
-
SETTINGS=${D}${settings_datadir}
install -d ${SETTINGS}
-
# gen_settings.pl replaces any MRW variables with their value
${bindir}/perl-native/perl \
${bindir}/gen_settings.pl \
@@ -35,3 +29,5 @@ do_install() {
${MRW_EXPRESSION_VARS} \
-f
}
+
+MRW_EXPRESSION_VARS ?= ""