summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-s6q/recipes-s6q
diff options
context:
space:
mode:
authorJerry Wan <jerry.wan@quantatw.com>2022-02-14 14:35:26 +0300
committerJerry Wan <jerry.wan@quantatw.com>2022-03-11 06:14:03 +0300
commitb63d8ff4c6caf32bf6c9467a3834b623d190e3ea (patch)
tree002a40d0f4b310c63e18ceed228b1b604d63b8aa /meta-quanta/meta-s6q/recipes-s6q
parent1fe1de3781843c487323e0408ec0949bd93e1c47 (diff)
downloadopenbmc-b63d8ff4c6caf32bf6c9467a3834b623d190e3ea.tar.xz
meta-quanta: s6q: Add usb0 network interface
1. Fix the sytle of systemd-conf.bbappend to wrap with 80 characters. 2. Add usb0 network interface. 3. Disable ipv4 link-local address to avoid routing problems. Tested: Set the host's network interface to a link-local address and successfully communicate with the BMC via usb0. Signed-off-by: Jerry Wan <jerry.wan@quantatw.com> Change-Id: I9e6a9946a2beb8cf85872abe1919e92052fe46cc
Diffstat (limited to 'meta-quanta/meta-s6q/recipes-s6q')
-rw-r--r--meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget.bb13
-rw-r--r--meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget/00-bmc-usb0.network8
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget.bb b/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget.bb
new file mode 100644
index 0000000000..6229879c3d
--- /dev/null
+++ b/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget.bb
@@ -0,0 +1,13 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+SRC_URI:append = " file://00-bmc-usb0.network"
+
+FILES:${PN}:append = " ${sysconfdir_native}/systemd/network/00-bmc-usb0.network"
+
+do_install() {
+ install -d ${D}${sysconfdir_native}/systemd/network/
+ install -m 0644 ${WORKDIR}/00-bmc-usb0.network \
+ ${D}${sysconfdir_native}/systemd/network
+}
diff --git a/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget/00-bmc-usb0.network b/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget/00-bmc-usb0.network
new file mode 100644
index 0000000000..44797f7c16
--- /dev/null
+++ b/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget/00-bmc-usb0.network
@@ -0,0 +1,8 @@
+[Match]
+Name=usb0
+[Network]
+DHCP=false
+LinkLocalAddressing=no
+IPv6AcceptRA=false
+[Address]
+Address=169.254.0.17/20