summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-s6q/recipes-s6q
diff options
context:
space:
mode:
Diffstat (limited to 'meta-quanta/meta-s6q/recipes-s6q')
-rw-r--r--meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget.bb13
-rw-r--r--meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget/00-bmc-usb0.network8
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget.bb b/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget.bb
new file mode 100644
index 0000000000..6229879c3d
--- /dev/null
+++ b/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget.bb
@@ -0,0 +1,13 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+SRC_URI:append = " file://00-bmc-usb0.network"
+
+FILES:${PN}:append = " ${sysconfdir_native}/systemd/network/00-bmc-usb0.network"
+
+do_install() {
+ install -d ${D}${sysconfdir_native}/systemd/network/
+ install -m 0644 ${WORKDIR}/00-bmc-usb0.network \
+ ${D}${sysconfdir_native}/systemd/network
+}
diff --git a/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget/00-bmc-usb0.network b/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget/00-bmc-usb0.network
new file mode 100644
index 0000000000..44797f7c16
--- /dev/null
+++ b/meta-quanta/meta-s6q/recipes-s6q/network/usb-ethernet-gadget/00-bmc-usb0.network
@@ -0,0 +1,8 @@
+[Match]
+Name=usb0
+[Network]
+DHCP=false
+LinkLocalAddressing=no
+IPv6AcceptRA=false
+[Address]
+Address=169.254.0.17/20