summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb43
1 files changed, 21 insertions, 22 deletions
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
index 651d51b7cb..4fcac31a46 100644
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
@@ -1,35 +1,34 @@
SUMMARY = "OpenBMC Buttons"
DESCRIPTION = "OpenBMC All buttons"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-S = "${WORKDIR}/git"
-SRC_URI += "git://github.com/openbmc/phosphor-buttons.git;branch=master;protocol=https"
+DEPENDS += " \
+ systemd \
+ sdbusplus \
+ phosphor-dbus-interfaces \
+ phosphor-logging \
+ "
SRCREV = "a6d4e65d5c4c78f86d690fff31b79db9fa8c3b4c"
-
-inherit meson pkgconfig systemd
-
-BUTTON_PACKAGES="${PN}-signals ${PN}-handler"
-
-ALLOW_EMPTY:${PN} = "1"
-PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"
PACKAGECONFIG ??= "signals handler"
-SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
-
PACKAGECONFIG[signals] = ",,gpioplus nlohmann-json,"
PACKAGECONFIG[handler] = ",,,phosphor-state-manager-chassis phosphor-state-manager-host"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
-FILES:${PN}-signals = "${bindir}/buttons"
+SRC_URI += "git://github.com/openbmc/phosphor-buttons.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
SYSTEMD_SERVICE:${PN}-signals = "xyz.openbmc_project.Chassis.Buttons.service"
+SYSTEMD_SERVICE:${PN}-handler = "phosphor-button-handler.service"
+
+inherit meson pkgconfig systemd
+FILES:${PN}-signals = "${bindir}/buttons"
FILES:${PN}-handler = "${bindir}/button-handler"
-SYSTEMD_SERVICE:${PN}-handler = "phosphor-button-handler.service"
-DEPENDS += " \
- systemd \
- sdbusplus \
- phosphor-dbus-interfaces \
- phosphor-logging \
- "
+ALLOW_EMPTY:${PN} = "1"
+
+BUTTON_PACKAGES = "${PN}-signals ${PN}-handler"
+
+PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"