summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/chassis
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/chassis')
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb6
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-host-failure-reboots.bb8
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb43
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-power_git.bb13
4 files changed, 34 insertions, 36 deletions
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb
index 3c62552c64..1f98bc0548 100644
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/obmc-control-chassis_git.bb
@@ -1,7 +1,9 @@
SUMMARY = "OpenBMC org.openbmc.control.Chassis example implementation"
DESCRIPTION = "An example implementation of the org.openbmc.control.Chassis DBUS API."
-PR = "r1"
PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SKELETON_DIR = "pychassisctl"
inherit skeleton-python
inherit obmc-phosphor-dbus-service
@@ -13,7 +15,5 @@ RDEPENDS:${PN} += "\
pyphosphor-dbus \
"
-SKELETON_DIR = "pychassisctl"
-
FMT = "org.openbmc.control.Chassis@{0}.service"
DBUS_SERVICE:${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-host-failure-reboots.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-host-failure-reboots.bb
index b21440d89b..42e6b25a62 100644
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-host-failure-reboots.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/obmc-host-failure-reboots.bb
@@ -1,15 +1,15 @@
SUMMARY = "Enables reboots on host failures"
DESCRIPTION = "Manages the settings entry that controls reboots \
on host failures"
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+PR = "r1"
+
+SYSTEMD_SERVICE:${PN} += "${TMPL}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'LINK_FMT', 'OBMC_HOST_INSTANCES')}"
inherit obmc-phosphor-systemd
TMPL = "host-failure-reboots@.service"
INSTFMT = "host-failure-reboots@{0}.service"
LINK_FMT = "${TMPL}:${INSTFMT}"
-
-SYSTEMD_SERVICE:${PN} += "${TMPL}"
-SYSTEMD_LINK:${PN} += "${@compose_list(d, 'LINK_FMT', 'OBMC_HOST_INSTANCES')}"
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
index 651d51b7cb..4fcac31a46 100644
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
@@ -1,35 +1,34 @@
SUMMARY = "OpenBMC Buttons"
DESCRIPTION = "OpenBMC All buttons"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-S = "${WORKDIR}/git"
-SRC_URI += "git://github.com/openbmc/phosphor-buttons.git;branch=master;protocol=https"
+DEPENDS += " \
+ systemd \
+ sdbusplus \
+ phosphor-dbus-interfaces \
+ phosphor-logging \
+ "
SRCREV = "a6d4e65d5c4c78f86d690fff31b79db9fa8c3b4c"
-
-inherit meson pkgconfig systemd
-
-BUTTON_PACKAGES="${PN}-signals ${PN}-handler"
-
-ALLOW_EMPTY:${PN} = "1"
-PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"
PACKAGECONFIG ??= "signals handler"
-SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
-
PACKAGECONFIG[signals] = ",,gpioplus nlohmann-json,"
PACKAGECONFIG[handler] = ",,,phosphor-state-manager-chassis phosphor-state-manager-host"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
-FILES:${PN}-signals = "${bindir}/buttons"
+SRC_URI += "git://github.com/openbmc/phosphor-buttons.git;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
SYSTEMD_SERVICE:${PN}-signals = "xyz.openbmc_project.Chassis.Buttons.service"
+SYSTEMD_SERVICE:${PN}-handler = "phosphor-button-handler.service"
+
+inherit meson pkgconfig systemd
+FILES:${PN}-signals = "${bindir}/buttons"
FILES:${PN}-handler = "${bindir}/button-handler"
-SYSTEMD_SERVICE:${PN}-handler = "phosphor-button-handler.service"
-DEPENDS += " \
- systemd \
- sdbusplus \
- phosphor-dbus-interfaces \
- phosphor-logging \
- "
+ALLOW_EMPTY:${PN} = "1"
+
+BUTTON_PACKAGES = "${PN}-signals ${PN}-handler"
+
+PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-power_git.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-power_git.bb
index bc42b9495b..b35c387fe5 100644
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-power_git.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-power_git.bb
@@ -1,17 +1,16 @@
SUMMARY = "Chassis Power Control"
HOMEPAGE = "https://github.com/openbmc/phosphor-power-control"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-inherit meson pkgconfig
-
DEPENDS += "phosphor-logging"
DEPENDS += "nlohmann-json"
DEPENDS += "gpioplus"
+SRCREV = "09fdcb592a9320b9363fb1c7fec872a69ac95189"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://github.com/openbmc/phosphor-power-control;branch=master;protocol=https"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/phosphor-power-control;branch=master;protocol=https"
-SRCREV = "09fdcb592a9320b9363fb1c7fec872a69ac95189"
+inherit meson pkgconfig