summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb80
1 files changed, 38 insertions, 42 deletions
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
index df482e68de..ac83d33102 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -2,17 +2,8 @@ SUMMARY = "Phosphor OpenBMC event and error logging"
DESCRIPTION = "An error and event log daemon application, and \
supporting tools for OpenBMC."
HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-inherit pkgconfig meson
-inherit python3native
-inherit obmc-phosphor-dbus-service
-inherit phosphor-logging
-inherit phosphor-dbus-yaml
-
DEPENDS += "systemd"
DEPENDS += "${PYTHON_PN}-mako-native"
DEPENDS += "${PYTHON_PN}-pyyaml-native"
@@ -24,51 +15,56 @@ DEPENDS += "virtual/phosphor-logging-callouts"
DEPENDS += "libcereal"
DEPENDS += "sdeventplus"
DEPENDS += "packagegroup-obmc-yaml-providers"
+SRCREV = "f2131442a3dd9ccb44aad106aa6f4c14e3c051ba"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[openpower-pels] = " \
+ -Dopenpower-pel-extension=enabled, \
+ -Dopenpower-pel-extension=disabled, \
+ nlohmann-json cli11 pldm python3, \
+ python3, \
+ "
+PV = "1.0+git${SRCPV}"
+PR = "r1"
-PACKAGE_BEFORE_PN = "${PN}-test"
-FILES:${PN}-test = "${bindir}/*-test"
-
-# Package configuration
-LOGGING_PACKAGES = " \
- ${PN}-base \
- phosphor-rsyslog-config \
-"
+SRC_URI += "git://github.com/openbmc/phosphor-logging;branch=master;protocol=https"
-ALLOW_EMPTY:${PN} = "1"
-PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
-DBUS_PACKAGES = "${LOGGING_PACKAGES}"
-USERADD_PACKAGES = "${PN}-base"
-GROUPADD_PARAM:${PN}-base = "-r phosphor-logging"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig meson
+inherit python3native
+inherit obmc-phosphor-dbus-service
+inherit phosphor-logging
+inherit phosphor-dbus-yaml
+EXTRA_OEMESON = " \
+ -Dtests=disabled \
+ -Dyamldir=${STAGING_DIR_TARGET}${yaml_dir} \
+ -Dcallout_yaml=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
+ "
+
+FILES:${PN}-test = "${bindir}/*-test"
FILES:${PN}-base += " \
${datadir}/dbus-1 \
${bindir}/phosphor-log-manager \
${libdir}/libphosphor_logging.so.* \
"
-DBUS_SERVICE:${PN}-base += "xyz.openbmc_project.Logging.service"
-
-DBUS_SERVICE:phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
FILES:phosphor-rsyslog-config += " \
${bindir}/phosphor-rsyslog-conf \
"
-SRC_URI += "git://github.com/openbmc/phosphor-logging;branch=master;protocol=https"
-SRCREV = "f2131442a3dd9ccb44aad106aa6f4c14e3c051ba"
-
-S = "${WORKDIR}/git"
-
-PACKAGECONFIG ??= ""
+ALLOW_EMPTY:${PN} = "1"
-PACKAGECONFIG[openpower-pels] = " \
- -Dopenpower-pel-extension=enabled, \
- -Dopenpower-pel-extension=disabled, \
- nlohmann-json cli11 pldm python3, \
- python3, \
- "
+USERADD_PACKAGES = "${PN}-base"
-EXTRA_OEMESON = " \
- -Dtests=disabled \
- -Dyamldir=${STAGING_DIR_TARGET}${yaml_dir} \
- -Dcallout_yaml=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
- "
+PACKAGE_BEFORE_PN = "${PN}-test"
+# Package configuration
+LOGGING_PACKAGES = " \
+ ${PN}-base \
+ phosphor-rsyslog-config \
+"
+PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
+DBUS_PACKAGES = "${LOGGING_PACKAGES}"
+GROUPADD_PARAM:${PN}-base = "-r phosphor-logging"
+DBUS_SERVICE:${PN}-base += "xyz.openbmc_project.Logging.service"
+DBUS_SERVICE:phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"