summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/logging
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/logging')
-rw-r--r--meta-phosphor/recipes-phosphor/logging/bios-bmc-smm-error-logger_git.bb19
-rw-r--r--meta-phosphor/recipes-phosphor/logging/ffdc_git.bb17
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb39
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb11
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-mrw-native.bb13
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb80
6 files changed, 82 insertions, 97 deletions
diff --git a/meta-phosphor/recipes-phosphor/logging/bios-bmc-smm-error-logger_git.bb b/meta-phosphor/recipes-phosphor/logging/bios-bmc-smm-error-logger_git.bb
index e1a2f459e8..139fd0faa9 100644
--- a/meta-phosphor/recipes-phosphor/logging/bios-bmc-smm-error-logger_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/bios-bmc-smm-error-logger_git.bb
@@ -1,11 +1,7 @@
SUMMARY = "BIOS BMC SMM Error Logger"
DESCRIPTION = "Allows BIOS in SMM to log errors to the BMC"
-PR = "r1"
-PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit meson pkgconfig systemd
-
DEPENDS += " \
boost \
fmt \
@@ -16,14 +12,17 @@ DEPENDS += " \
sdbusplus \
phosphor-dbus-interfaces \
"
+SRCREV = "3def3c8eede08d82e709333445bc543ef4861bcd"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
-EXTRA_OEMESON = " \
- -Dtests=disabled \
-"
+SRC_URI = "git://github.com/openbmc/bios-bmc-smm-error-logger;branch=main;protocol=https"
S = "${WORKDIR}/git"
+SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.bios_bmc_smm_error_logger.service"
-SRC_URI = "git://github.com/openbmc/bios-bmc-smm-error-logger;branch=main;protocol=https"
-SRCREV = "3def3c8eede08d82e709333445bc543ef4861bcd"
+inherit meson pkgconfig systemd
-SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.bios_bmc_smm_error_logger.service"
+EXTRA_OEMESON = " \
+ -Dtests=disabled \
+"
diff --git a/meta-phosphor/recipes-phosphor/logging/ffdc_git.bb b/meta-phosphor/recipes-phosphor/logging/ffdc_git.bb
index 3b05b9e022..b87dbcc5e1 100644
--- a/meta-phosphor/recipes-phosphor/logging/ffdc_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/ffdc_git.bb
@@ -1,15 +1,8 @@
SUMMARY = "FFDC collector script"
DESCRIPTION = "Command line tool to collect and tar up debug data"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
-require recipes-phosphor/dump/phosphor-debug-collector.inc
-
DEPENDS += "systemd"
-
-RDEPENDS:${PN} += " \
- ${VIRTUAL-RUNTIME_base-utils} \
- "
+PV = "1.0+git${SRCPV}"
+PR = "r1"
S = "${WORKDIR}/git"
@@ -18,3 +11,9 @@ do_install() {
install -m 0755 ffdc \
${D}${bindir}/ffdc
}
+
+RDEPENDS:${PN} += " \
+ ${VIRTUAL-RUNTIME_base-utils} \
+ "
+
+require recipes-phosphor/dump/phosphor-debug-collector.inc
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb
index e574682afc..4da5b49f7a 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-hostlogger_git.bb
@@ -1,60 +1,55 @@
SUMMARY = "Phosphor Host logger"
DESCRIPTION = "Save log messages from host's console to the persistent storage."
HOMEPAGE = "https://github.com/openbmc/phosphor-hostlogger"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
-inherit pkgconfig meson
-inherit systemd
-
# License info
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
# Dependencies
DEPENDS += " \
phosphor-logging \
zlib \
"
-RDEPENDS:${PN} += "obmc-console"
-RRECOMMENDS:${PN} += "phosphor-debug-collector"
+SRCREV = "d68863396c608912a820926d8d98d92499f49ac2"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://github.com/openbmc/phosphor-hostlogger;branch=master;protocol=https"
# Source code repository
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/phosphor-hostlogger;branch=master;protocol=https"
-SRCREV = "d68863396c608912a820926d8d98d92499f49ac2"
+# Systemd service template
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "hostlogger@.service"
+# Preset systemd units
+SYSTEMD_SERVICE:${PN} += "${@'${CUSTOM_SERVICES}' if len('${CUSTOM_SERVICES}') \
+ else '${DEFAULT_SERVICE}'}"
+
+inherit pkgconfig meson
+inherit systemd
# Disable unit tests
EXTRA_OEMESON:append = " -Dtests=disabled"
-# Systemd service template
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "hostlogger@.service"
+RDEPENDS:${PN} += "obmc-console"
+
+RRECOMMENDS:${PN} += "phosphor-debug-collector"
# Default service instance to install (single-host mode)
DEFAULT_INSTANCE = "ttyVUART0"
DEFAULT_SERVICE = "hostlogger@${DEFAULT_INSTANCE}.service"
-
# Multi-host mode setup - list of configuration files to install, can be added
# via SRC_URI in a bbappend. The file name is the name of the service instance,
# which should match the corresponding instance of the obmc-console service.
CUSTOM_CONFIGS = "${@custom_configs('${WORKDIR}')}"
CUSTOM_SERVICES = "${@custom_services('${CUSTOM_CONFIGS}')}"
-
-# Preset systemd units
-SYSTEMD_SERVICE:${PN} += "${@'${CUSTOM_SERVICES}' if len('${CUSTOM_SERVICES}') \
- else '${DEFAULT_SERVICE}'}"
-
# Gets list of custom config files in a directory
def custom_configs(workdir):
if os.path.exists(workdir):
return ' '.join([f for f in os.listdir(workdir) if f.endswith('.conf')])
-
# Get list of custom service instances
def custom_services(configs):
return ' '.join(['hostlogger@' + i.replace('.conf', '.service') \
for i in configs.split()])
-
do_install:append() {
# Install config files
if [ -n "${CUSTOM_CONFIGS}" ]; then
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
index 88baca5b03..bffa543201 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-example-native.bb
@@ -1,17 +1,16 @@
SUMMARY = "Generated callout information for phosphor-logging"
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit phosphor-logging
-inherit native
+PROVIDES += "virtual/phosphor-logging-callouts"
+PR = "r1"
SRC_URI += "file://callouts.yaml"
-PROVIDES += "virtual/phosphor-logging-callouts"
-
S = "${WORKDIR}"
+inherit phosphor-logging
+inherit native
+
do_install() {
DEST=${D}${callouts_datadir}
install -d ${DEST}
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-mrw-native.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-mrw-native.bb
index 6bb86915eb..e76e9e7b3b 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-mrw-native.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging-callouts-mrw-native.bb
@@ -1,25 +1,22 @@
SUMMARY = "Generated callout information for phosphor-logging"
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit phosphor-logging
-inherit mrw-xml
-inherit native
-
DEPENDS += " \
mrw-native \
mrw-perl-tools-native \
"
-
PROVIDES += "virtual/phosphor-logging-callouts"
+PR = "r1"
S = "${WORKDIR}"
+inherit phosphor-logging
+inherit mrw-xml
+inherit native
+
do_install() {
DEST=${D}${callouts_datadir}
install -d ${DEST}
-
${bindir}/perl-native/perl \
${bindir}/gen_callouts.pl \
-m ${mrw_datadir}/${MRW_XML} \
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
index df482e68de..ac83d33102 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -2,17 +2,8 @@ SUMMARY = "Phosphor OpenBMC event and error logging"
DESCRIPTION = "An error and event log daemon application, and \
supporting tools for OpenBMC."
HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-inherit pkgconfig meson
-inherit python3native
-inherit obmc-phosphor-dbus-service
-inherit phosphor-logging
-inherit phosphor-dbus-yaml
-
DEPENDS += "systemd"
DEPENDS += "${PYTHON_PN}-mako-native"
DEPENDS += "${PYTHON_PN}-pyyaml-native"
@@ -24,51 +15,56 @@ DEPENDS += "virtual/phosphor-logging-callouts"
DEPENDS += "libcereal"
DEPENDS += "sdeventplus"
DEPENDS += "packagegroup-obmc-yaml-providers"
+SRCREV = "f2131442a3dd9ccb44aad106aa6f4c14e3c051ba"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[openpower-pels] = " \
+ -Dopenpower-pel-extension=enabled, \
+ -Dopenpower-pel-extension=disabled, \
+ nlohmann-json cli11 pldm python3, \
+ python3, \
+ "
+PV = "1.0+git${SRCPV}"
+PR = "r1"
-PACKAGE_BEFORE_PN = "${PN}-test"
-FILES:${PN}-test = "${bindir}/*-test"
-
-# Package configuration
-LOGGING_PACKAGES = " \
- ${PN}-base \
- phosphor-rsyslog-config \
-"
+SRC_URI += "git://github.com/openbmc/phosphor-logging;branch=master;protocol=https"
-ALLOW_EMPTY:${PN} = "1"
-PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
-DBUS_PACKAGES = "${LOGGING_PACKAGES}"
-USERADD_PACKAGES = "${PN}-base"
-GROUPADD_PARAM:${PN}-base = "-r phosphor-logging"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig meson
+inherit python3native
+inherit obmc-phosphor-dbus-service
+inherit phosphor-logging
+inherit phosphor-dbus-yaml
+EXTRA_OEMESON = " \
+ -Dtests=disabled \
+ -Dyamldir=${STAGING_DIR_TARGET}${yaml_dir} \
+ -Dcallout_yaml=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
+ "
+
+FILES:${PN}-test = "${bindir}/*-test"
FILES:${PN}-base += " \
${datadir}/dbus-1 \
${bindir}/phosphor-log-manager \
${libdir}/libphosphor_logging.so.* \
"
-DBUS_SERVICE:${PN}-base += "xyz.openbmc_project.Logging.service"
-
-DBUS_SERVICE:phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
FILES:phosphor-rsyslog-config += " \
${bindir}/phosphor-rsyslog-conf \
"
-SRC_URI += "git://github.com/openbmc/phosphor-logging;branch=master;protocol=https"
-SRCREV = "f2131442a3dd9ccb44aad106aa6f4c14e3c051ba"
-
-S = "${WORKDIR}/git"
-
-PACKAGECONFIG ??= ""
+ALLOW_EMPTY:${PN} = "1"
-PACKAGECONFIG[openpower-pels] = " \
- -Dopenpower-pel-extension=enabled, \
- -Dopenpower-pel-extension=disabled, \
- nlohmann-json cli11 pldm python3, \
- python3, \
- "
+USERADD_PACKAGES = "${PN}-base"
-EXTRA_OEMESON = " \
- -Dtests=disabled \
- -Dyamldir=${STAGING_DIR_TARGET}${yaml_dir} \
- -Dcallout_yaml=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
- "
+PACKAGE_BEFORE_PN = "${PN}-test"
+# Package configuration
+LOGGING_PACKAGES = " \
+ ${PN}-base \
+ phosphor-rsyslog-config \
+"
+PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
+DBUS_PACKAGES = "${LOGGING_PACKAGES}"
+GROUPADD_PARAM:${PN}-base = "-r phosphor-logging"
+DBUS_SERVICE:${PN}-base += "xyz.openbmc_project.Logging.service"
+DBUS_SERVICE:phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"