summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-support')
-rw-r--r--meta-phosphor/recipes-support/boost/boost_%.bbappend4
-rw-r--r--meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb58
-rw-r--r--meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend1
-rw-r--r--meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend9
4 files changed, 31 insertions, 41 deletions
diff --git a/meta-phosphor/recipes-support/boost/boost_%.bbappend b/meta-phosphor/recipes-support/boost/boost_%.bbappend
index 475c830c7b..eb16acaa21 100644
--- a/meta-phosphor/recipes-support/boost/boost_%.bbappend
+++ b/meta-phosphor/recipes-support/boost/boost_%.bbappend
@@ -1,3 +1,5 @@
+PACKAGECONFIG:openbmc-phosphor:class-target = ""
+
#This is largely to improve our build times by not building or installing
#modules that OpenBMC does not use by our coding standard. Another thing to
#note is that for most targets, coroutine and context libraries are also added
@@ -9,5 +11,3 @@
#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
#
BOOST_LIBS:openbmc-phosphor:class-target = "chrono thread context coroutine"
-PACKAGECONFIG:openbmc-phosphor:class-target = ""
-
diff --git a/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb b/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
index 04e6a7e096..8c699a8b44 100644
--- a/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
+++ b/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
@@ -5,57 +5,49 @@ DESCRIPTION = "\
system information from LDAP. It is used by the libnss-ldapd and \
libpam-ldapd packages but is not very useful by itself. \
"
-
HOMEPAGE = "http://arthurdejong.org/nss-pam-ldapd/"
-
+SECTION = "base"
LICENSE = "LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-SECTION = "base"
-
FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+DEPENDS += "libpam openldap krb5"
SRC_URI = "\
- http://arthurdejong.org/nss-pam-ldapd/${BPN}-${PV}.tar.gz \
- file://nslcd.init \
- file://nslcd.service \
- "
-
-inherit autotools
-
+ http://arthurdejong.org/nss-pam-ldapd/${BPN}-${PV}.tar.gz \
+ file://nslcd.init \
+ file://nslcd.service \
+ "
SRC_URI[md5sum] = "8c99fdc54f4bf9aca8c5f53fdb1403ff"
SRC_URI[sha256sum] = "ef7362e7f2003da8c7beb7bcc03c30494acf712625aaac8badc6e7eb16f3453f"
-DEPENDS += "libpam openldap krb5"
+SYSTEMD_SERVICE:${PN} = "nslcd.service"
-RDEPENDS:${PN} += "nscd"
+inherit autotools
+inherit update-rc.d systemd
EXTRA_OECONF = "\
- --disable-pynslcd \
- --libdir=${base_libdir} \
- --with-pam-seclib-dir=${base_libdir}/security \
- "
-
-CONFFILES:${PN} += "${sysconfdir}/nslcd.conf"
-
-FILES:${PN} += "${base_libdir}/security ${datadir}"
-FILES:${PN}-dbg += "${base_libdir}/security/.debug"
-
-LDAP_DN ?= "dc=my-domain,dc=com"
+ --disable-pynslcd \
+ --libdir=${base_libdir} \
+ --with-pam-seclib-dir=${base_libdir}/security \
+ "
do_install:append() {
- install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd
+ install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd
+ sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf
+ sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
+ sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_system_unitdir}
+}
- sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf
- sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
- sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
+RDEPENDS:${PN} += "nscd"
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_system_unitdir}
-}
+FILES:${PN} += "${base_libdir}/security ${datadir}"
+FILES:${PN}-dbg += "${base_libdir}/security/.debug"
-inherit update-rc.d systemd
+CONFFILES:${PN} += "${sysconfdir}/nslcd.conf"
INITSCRIPT_NAME = "nslcd"
INITSCRIPT_PARAMS = "defaults"
-SYSTEMD_SERVICE:${PN} = "nslcd.service"
+LDAP_DN ?= "dc=my-domain,dc=com"
diff --git a/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend b/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
index 58ab64aae7..98f94a7af0 100644
--- a/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
+++ b/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
@@ -1,5 +1,4 @@
do_install:append() {
sed -i -e '$anss_initgroups_ignoreusers ALLLOCAL' ${D}${sysconfdir}/nslcd.conf
-
install -m 0644 ${D}${sysconfdir}/nslcd.conf ${D}${sysconfdir}/nslcd.conf.default
}
diff --git a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
index 98e8130a45..ab6f528af7 100644
--- a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
+++ b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
@@ -1,17 +1,14 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://10-nice.conf"
-
PACKAGECONFIG:remove = "\
${@bb.utils.contains('MACHINE_FEATURES', 'hw-rng', \
'libjitterentropy', '', d)}\
"
-inherit systemd
+SRC_URI += "file://10-nice.conf"
-FILES:${PN} += "${systemd_system_unitdir}/rngd.service.d"
+inherit systemd
do_install:append() {
-
# When using systemd and using libjitterentropy, install a config
# which runs rngd at a 'nice' priority. libjitterentropy uses a
# lot of CPU early on in the boot process and makes the whole boot
@@ -24,3 +21,5 @@ do_install:append() {
fi
fi
}
+
+FILES:${PN} += "${systemd_system_unitdir}/rngd.service.d"