summaryrefslogtreecommitdiff
path: root/meta-quanta
diff options
context:
space:
mode:
Diffstat (limited to 'meta-quanta')
-rwxr-xr-xmeta-quanta/meta-common/recipes-phosphor/health/files/bmc_health_config.json15
-rwxr-xr-xmeta-quanta/meta-common/recipes-phosphor/health/phosphor-health-monitor_%.bbappend9
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-quanta/meta-common/recipes-phosphor/health/files/bmc_health_config.json b/meta-quanta/meta-common/recipes-phosphor/health/files/bmc_health_config.json
new file mode 100755
index 0000000000..373b5d50fc
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-phosphor/health/files/bmc_health_config.json
@@ -0,0 +1,15 @@
+{
+ "CPU" : {
+ "Frequency" : 1,
+ "Window_size": 120
+ },
+ "Memory" : {
+ "Frequency" : 1,
+ "Window_size": 120
+ },
+ "Storage_RW" : {
+ "Path" : "/run/initramfs/rw",
+ "Frequency" : 1,
+ "Window_size": 120
+ }
+}
diff --git a/meta-quanta/meta-common/recipes-phosphor/health/phosphor-health-monitor_%.bbappend b/meta-quanta/meta-common/recipes-phosphor/health/phosphor-health-monitor_%.bbappend
new file mode 100755
index 0000000000..1d8bb4ecde
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-phosphor/health/phosphor-health-monitor_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI_append = " file://bmc_health_config.json \
+ "
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/healthMon/
+ install -m 0644 ${WORKDIR}/bmc_health_config.json ${D}/${sysconfdir}/healthMon/
+}
+