summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-devtools')
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-rtimu/0001-setup.py-Port-to-use-setuptools.patch29
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb2
-rw-r--r--meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-setup.py-Use-setuptools-instead-of-distutils.patch28
-rw-r--r--meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb6
4 files changed, 62 insertions, 3 deletions
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-rtimu/0001-setup.py-Port-to-use-setuptools.patch b/meta-raspberrypi/recipes-devtools/python/python3-rtimu/0001-setup.py-Port-to-use-setuptools.patch
new file mode 100644
index 0000000000..77eca99876
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-rtimu/0001-setup.py-Port-to-use-setuptools.patch
@@ -0,0 +1,29 @@
+From f5ab30abd37ee884fb3ccaad0a8d21108ca2c812 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 28 Feb 2022 21:37:19 -0800
+Subject: [PATCH] setup.py: Port to use setuptools
+
+Needed to get it going with wheel, distutils is deprecated for long
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Linux/python/setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Linux/python/setup.py b/Linux/python/setup.py
+index e429e6f..da96843 100644
+--- a/Linux/python/setup.py
++++ b/Linux/python/setup.py
+@@ -22,7 +22,7 @@
+ #// OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ #// SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-from distutils.core import setup, Extension
++from setuptools import setup, Extension
+ import os.path
+
+ RTIMU_sources = [
+--
+2.35.1
+
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb b/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
index c9f1cec6ac..1afbb5f169 100644
--- a/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
+++ b/meta-raspberrypi/recipes-devtools/python/python3-rtimu_git.bb
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://../../LICENSE;md5=96cdecb41125f498958e09b72faf318e"
SRC_URI = "git://github.com/RPi-Distro/RTIMULib.git;protocol=http;branch=master;protocol=https \
file://0001-include-asm-ioctl.h-for-ioctl-define.patch;patchdir=../.. \
+ file://0001-setup.py-Port-to-use-setuptools.patch;patchdir=../.. \
"
SRCREV = "b949681af69b45f0f7f4bb53b6770037b5b02178"
S = "${WORKDIR}/git/Linux/python"
-
inherit setuptools3
diff --git a/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-setup.py-Use-setuptools-instead-of-distutils.patch b/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-setup.py-Use-setuptools-instead-of-distutils.patch
new file mode 100644
index 0000000000..33480b12ce
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/rpi-gpio/0001-setup.py-Use-setuptools-instead-of-distutils.patch
@@ -0,0 +1,28 @@
+From df5657d772accb275a12c1b1690befa8d87305c8 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 5 Mar 2022 09:53:41 -0800
+Subject: [PATCH] setup.py: Use setuptools instead of distutils
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 2b600ca..0fa0807 100644
+--- a/setup.py
++++ b/setup.py
+@@ -20,7 +20,7 @@ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
+ """
+
+-from distutils.core import setup, Extension
++from setuptools import setup, Extension
+
+ classifiers = ['Development Status :: 5 - Production/Stable',
+ 'Operating System :: POSIX :: Linux',
+--
+2.35.1
+
diff --git a/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb b/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
index 574021ec41..039d1769e8 100644
--- a/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
+++ b/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
@@ -5,10 +5,12 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7"
PYPI_PACKAGE = "RPi.GPIO"
+
inherit pypi setuptools3
-SRC_URI += "file://0001-Remove-nested-functions.patch"
-SRC_URI[md5sum] = "777617f9dea9a1680f9af43db0cf150e"
+SRC_URI += "file://0001-Remove-nested-functions.patch \
+ file://0001-setup.py-Use-setuptools-instead-of-distutils.patch \
+ "
SRC_URI[sha256sum] = "7424bc6c205466764f30f666c18187a0824077daf20b295c42f08aea2cb87d3f"
COMPATIBLE_MACHINE = "^rpi$"