summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-extended
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-extended')
-rw-r--r--meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb14
-rw-r--r--meta-phosphor/recipes-extended/libbej/libbej_git.bb14
-rw-r--r--meta-phosphor/recipes-extended/pam/libpam_%.bbappend14
-rw-r--r--meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb13
-rw-r--r--meta-phosphor/recipes-extended/rsyslog/rsyslog_%.bbappend9
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb19
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb15
-rw-r--r--meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb19
-rw-r--r--meta-phosphor/recipes-extended/stdplus/stdplus_git.bb24
9 files changed, 68 insertions, 73 deletions
diff --git a/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb b/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
index e611b46099..c0137e3163 100644
--- a/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
+++ b/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
@@ -1,10 +1,15 @@
SUMMARY = "C++ bindings for linux gpio APIs"
DESCRIPTION = "C++ bindings for linux gpio APIs."
HOMEPAGE = "http://github.com/openbmc/gpioplus"
-PR = "r1"
-PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+SRCREV = "8944f2e24ad8152793af010906faf06607f0e04b"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "git://github.com/openbmc/gpioplus;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
inherit meson pkgconfig
@@ -12,8 +17,3 @@ EXTRA_OEMESON = " \
-Dexamples=false \
-Dtests=disabled \
"
-
-SRC_URI += "git://github.com/openbmc/gpioplus;branch=master;protocol=https"
-SRCREV = "8944f2e24ad8152793af010906faf06607f0e04b"
-
-S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-extended/libbej/libbej_git.bb b/meta-phosphor/recipes-extended/libbej/libbej_git.bb
index 858534999e..842dd92bdd 100644
--- a/meta-phosphor/recipes-extended/libbej/libbej_git.bb
+++ b/meta-phosphor/recipes-extended/libbej/libbej_git.bb
@@ -1,17 +1,17 @@
SUMMARY = "Binary Encoded JSON library"
DESCRIPTION = "Used to decode Redfish Device Enablement (RDE) BEJ"
-PR = "r1"
-PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+SRCREV = "cc4098e1508eede5887724fc68119a5e12fc3f96"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "git://github.com/openbmc/libbej;branch=main;protocol=https"
+
+S = "${WORKDIR}/git"
inherit meson pkgconfig
EXTRA_OEMESON = " \
-Dtests=disabled \
"
-
-SRC_URI += "git://github.com/openbmc/libbej;branch=main;protocol=https"
-SRCREV = "cc4098e1508eede5887724fc68119a5e12fc3f96"
-
-S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-extended/pam/libpam_%.bbappend b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
index 682f132b53..658dc0beec 100644
--- a/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
+++ b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
@@ -6,13 +6,6 @@ SRC_URI += " file://pam.d/common-password \
file://pam.d/common-session \
"
-RDEPENDS:${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \
- ${MLPREFIX}pam-plugin-tally2-${libpam_suffix} \
- ${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \
- ${MLPREFIX}pam-plugin-succeed-if-${libpam_suffix} \
- ${MLPREFIX}pam-plugin-localuser-${libpam_suffix} \
- "
-
do_install:append() {
# The libpam recipe will always add a pam_systemd.so line to
# common-session if systemd is enabled; however systemd only
@@ -20,3 +13,10 @@ do_install:append() {
# that package. So, remove the pam_systemd.so line here.
sed -i '/pam_systemd.so/d' ${D}${sysconfdir}/pam.d/common-session
}
+
+RDEPENDS:${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \
+ ${MLPREFIX}pam-plugin-tally2-${libpam_suffix} \
+ ${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \
+ ${MLPREFIX}pam-plugin-succeed-if-${libpam_suffix} \
+ ${MLPREFIX}pam-plugin-localuser-${libpam_suffix} \
+ "
diff --git a/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb b/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb
index ee362a6f75..3044f6b4d9 100644
--- a/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb
+++ b/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb
@@ -1,21 +1,20 @@
SUMMARY = "PAM modules for IPMI support"
DESCRIPTION = "PAM modules managing password for IPMI"
HOMEPAGE = "http://github.com/openbmc/pam-ipmi"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "openssl libpam"
+SRCREV = "c971bebca35d9f697a7a9e3efae3c66867e5b68d"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
SRC_URI += "git://github.com/openbmc/pam-ipmi;branch=master;protocol=https"
-SRCREV = "c971bebca35d9f697a7a9e3efae3c66867e5b68d"
+
S = "${WORKDIR}/git"
inherit autotools pkgconfig
-DEPENDS += "autoconf-archive-native"
-DEPENDS += "openssl libpam"
-
FILES:${PN} += " \
${base_libdir}/security/ \
${sysconfdir}/key_file \
diff --git a/meta-phosphor/recipes-extended/rsyslog/rsyslog_%.bbappend b/meta-phosphor/recipes-extended/rsyslog/rsyslog_%.bbappend
index f04f63dd25..c87b51a81e 100644
--- a/meta-phosphor/recipes-extended/rsyslog/rsyslog_%.bbappend
+++ b/meta-phosphor/recipes-extended/rsyslog/rsyslog_%.bbappend
@@ -1,15 +1,14 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+PACKAGECONFIG ??= " \
+ rsyslogd rsyslogrt inet regexp uuid \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
+"
SRC_URI += " \
file://rsyslog.conf \
file://server.conf \
"
-PACKAGECONFIG ??= " \
- rsyslogd rsyslogrt inet regexp uuid \
- ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
-"
-
do_install:append(){
install -m 0644 -D ${WORKDIR}/server.conf \
${D}${sysconfdir}/rsyslog.d/server.conf
diff --git a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
index d0443d1ce6..f682b62c95 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
@@ -1,12 +1,5 @@
SUMMARY = "sdbus++ dbus API / binding generator"
DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs"
-
-PYPI_PACKAGE = "sdbusplus"
-PV = "1.0"
-inherit setuptools3
-
-include sdbusplus-rev.inc
-
## The sdbusplus repository has an Apache LICENSE file, which we would
## normally check here, but the python setup script is in a subdirectory
## which requires us to set ${S} below. When we change ${S} from the root
@@ -14,14 +7,18 @@ include sdbusplus-rev.inc
## to the common Apache license file in poky's meta instead.
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-S="${WORKDIR}/git/tools"
-
DEPENDS += " \
${PYTHON_PN}-inflection-native \
${PYTHON_PN}-mako-native \
${PYTHON_PN}-pyyaml-native \
"
+PV = "1.0"
+
+PYPI_PACKAGE = "sdbusplus"
+
+S = "${WORKDIR}/git/tools"
+
+inherit setuptools3
RDEPENDS:${PN} += " \
${PYTHON_PN}-inflection \
@@ -29,4 +26,6 @@ RDEPENDS:${PN} += " \
${PYTHON_PN}-pyyaml \
"
+include sdbusplus-rev.inc
+
BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
index 454ca60974..28b76d0e20 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
@@ -1,15 +1,7 @@
SUMMARY = "C++ bindings for systemd dbus APIs"
DESCRIPTION = "C++ bindings for systemd dbus APIs."
-
-inherit pkgconfig meson
-inherit python3native
-include sdbusplus-rev.inc
-
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-S = "${WORKDIR}/git"
-
DEPENDS += " \
${PYTHON_PN}-inflection-native \
${PYTHON_PN}-mako-native \
@@ -18,7 +10,14 @@ DEPENDS += " \
systemd \
"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig meson
+inherit python3native
+
EXTRA_OEMESON:append = " \
-Dtests=disabled \
-Dexamples=disabled \
"
+
+include sdbusplus-rev.inc
diff --git a/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb b/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb
index 3b9d266607..72f78020b4 100644
--- a/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb
@@ -1,25 +1,24 @@
SUMMARY = "C++ bindings for systemd event APIs"
DESCRIPTION = "C++ bindings for systemd event APIs."
HOMEPAGE = "http://github.com/openbmc/sdeventplus"
-PR = "r1"
-PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-inherit meson pkgconfig
-
DEPENDS += " \
function2 \
stdplus \
systemd \
"
+SRCREV = "13afebfaa6a2bbb0bc03f4382eb6ba1c50fa6d4d"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "git://github.com/openbmc/sdeventplus;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig
EXTRA_OEMESON = " \
-Dexamples=false \
-Dtests=disabled \
"
-
-SRC_URI += "git://github.com/openbmc/sdeventplus;branch=master;protocol=https"
-SRCREV = "13afebfaa6a2bbb0bc03f4382eb6ba1c50fa6d4d"
-
-S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
index 8308dc1d27..2714e36648 100644
--- a/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
+++ b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
@@ -1,22 +1,21 @@
SUMMARY = "Common C++ functions"
DESCRIPTION = "Common C++ functions."
HOMEPAGE = "http://github.com/openbmc/stdplus"
-PR = "r1"
-PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-inherit meson pkgconfig
-
DEPENDS += " \
fmt \
liburing \
"
+SRCREV = "aa4fcfc208c45511aa9788a08c969425e440fda0"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
-PACKAGES =+ "libstdplus libstdplus-dl libstdplus-io_uring"
-FILES:libstdplus = "${libdir}/libstdplus.so.*"
-FILES:libstdplus-dl = "${libdir}/libstdplus-dl.so.*"
-FILES:libstdplus-io_uring = "${libdir}/libstdplus-io_uring.so.*"
+SRC_URI += "git://github.com/openbmc/stdplus;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig
EXTRA_OEMESON = " \
-Dexamples=false \
@@ -24,7 +23,8 @@ EXTRA_OEMESON = " \
-Dgtest=disabled \
"
-SRC_URI += "git://github.com/openbmc/stdplus;branch=master;protocol=https"
-SRCREV = "aa4fcfc208c45511aa9788a08c969425e440fda0"
+PACKAGES =+ "libstdplus libstdplus-dl libstdplus-io_uring"
-S = "${WORKDIR}/git"
+FILES:libstdplus = "${libdir}/libstdplus.so.*"
+FILES:libstdplus-dl = "${libdir}/libstdplus-dl.so.*"
+FILES:libstdplus-io_uring = "${libdir}/libstdplus-io_uring.so.*"